Großes Problem .....

Linux (Theli bezogen), Theli, GUI und Hilfsprogramme.
Forumsregeln
Bitte die Beiträge kurz fassen, so kann man sie nachher besser finden. Sollte ein Problem gelöst sein, dann einen neuen Beitrag eröffnen. Ebenso wenn die Ursache eine ganz andere ist, oder es Offtopic wird.

Großes Problem .....

Beitragvon Holger » Mittwoch 21. Mai 2014, 19:02

Hallo Linux- und Theli-Versteher,

der Aufruf
sudo apt-get install python python-dev python-numpy python-scipy python-astropy

führt momentan auf Ubuntu 10.04. und 12.04 zu einer Fehlermeldung.
Und das nicht nur bei mir.
Auch Rocky hatte sich seine Ubuntu/Theli Version zerschossen und wollte alles neu installieren.
Er hat die selben Fehlermeldungen und Probleme wie ich.

Es scheint sich da wohl um ein generelles Problem zu handeln.

Was nun???????
Gruß und CS
Holger
Holger
 
Beiträge: 165
Registriert: Donnerstag 29. September 2011, 16:02
Wohnort: Berlin - Buckow

Re: Großes Problem .....

Beitragvon rhess » Mittwoch 21. Mai 2014, 21:06

Hallo Holger,

ich habe mittlerweile Theli wieder zum laufen gebracht :D

Was habe ich gemacht ? Nun, ich habe Ubuntu 12.04 installiert, wie du richtig geschrieben hast kommt eine Fehlermeldung
wenn man den Befehl

sudo apt-get install python python-dev python-numpy python-scipy python-astropy


eingibt, es wird das Paket python-astropy nicht gefunden.
Ich hab mich dann auf der Homepage von http://www.astropy.org schlau gemacht und das Paket mit dem Befehl

sudo apt-get install python-pip


installiert.
Vielleicht könnte Mischa oder jemand anders bestätigen das dieses python-pip dieses astropy Paket ist ?!
Oder muss da noch etwas nachinstalliert werden ?

Danach habe ich alle Pakete wie gehabt von Mischa's Anleitung nachinstalliert, die 4. Zeile aus Mischa's Anleitung eben ohne "python-astropy" !

Danach wie gehabt Theli und die GUI installiert, es lief alles ohne Fehlermeldungen durch und Theli läuft nun wieder !
Ich muss allerdings erst noch einen Testdurchlauf mit meinen Daten machen um zu sehen das auch wirklich alles funktioniert !

Grüße
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10

Re: Großes Problem .....

Beitragvon rhess » Mittwoch 21. Mai 2014, 22:04

Hallo,

Bei der Astrometrie kommt die Fehlermeldung

Import Error: No module named pyfits

Es scheint also doch noch das Paket python-astropy zu fehlen !

Wie gesagt mit
sudo apt-get install python-astropy
kommt die Meldung das dieses Paket nicht gefunden werden kann !

Daran scheitert das ganze !

Grüße
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10

Re: Großes Problem .....

Beitragvon mischa » Donnerstag 22. Mai 2014, 01:18

rhess hat geschrieben:Import Error: No module named pyfits

Es scheint also doch noch das Paket python-astropy zu fehlen !


Unter Ubuntu 14.04 LTS ist es jedenfalls so vorhanden. Kann sein, dass es fuer aeltere Ubuntu-Versionen so noch nicht vorliegt. Dann muss man es halt ueber 'pip' installieren, wie auf astropython.org beschrieben ist.

'pip' ist lediglich ein python installer und hat mit astropy m.W. nach nichts zu tun.

Das obsolete 'pyfits' wird benoetigt, falls die Astrometrie mit 'astrometry.net' gemacht wird, ansonsten ist es durch astropython ersetzt worden.
Paketname unter 12.04: python-pyfits

mischa
mischa
Moderator
 
Beiträge: 971
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Großes Problem .....

Beitragvon rhess » Donnerstag 22. Mai 2014, 20:55

Hallo Mischa,

hab jetzt astropy unter Ubuntu 12.04 installiert.

sudo apt-get install python-pip

und
sudo pip install astropy


Ich hoffe das war richtig so, jedenfalls ist die Installation problemlos durchgelaufen, natürlich habe ich auch alle anderen Pakete installiert.

Die Theli und GUI installation ging auch ohne Probleme.

Jetzt aber mein neues Problem, bei der Astrometrie mit Scamp kommt folgende Fehlermeldung

/home/hess/THELI/theli//bin/Linux_64//scamp: error while loading shared libraries: libplplotd.so.11: cannot open shared object file: No such file or directory


Wie kann ich dieses Problem lösen ?

Grüße
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10

Re: Großes Problem .....

Beitragvon mischa » Donnerstag 22. Mai 2014, 23:05

rhess hat geschrieben:Jetzt aber mein neues Problem, bei der Astrometrie mit Scamp kommt folgende Fehlermeldung

/home/hess/THELI/theli//bin/Linux_64//scamp: error while loading shared libraries: libplplotd.so.11: cannot open shared object file: No such file or directory


Wie kann ich dieses Problem lösen ?


Da hast du wohl eine der neuen scamp versionen gezogen und nicht mehr die alte 1.4.6?
Dann fehlt dir die 'plplot' library, unter 12.04 heisst die

Code: Alles auswählen
sudo apt-get install libplplot11


mischa
mischa
Moderator
 
Beiträge: 971
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Großes Problem .....

Beitragvon Holger » Donnerstag 22. Mai 2014, 23:08

Hallo Mischa,

Da hast du wohl eine der neuen scamp versionen gezogen und nicht mehr die alte 1.4.6?

Das die Scamp Version die du verlinkt hast.
Gruß und CS
Holger
Holger
 
Beiträge: 165
Registriert: Donnerstag 29. September 2011, 16:02
Wohnort: Berlin - Buckow

Re: Großes Problem .....

Beitragvon mischa » Freitag 23. Mai 2014, 03:51

Holger hat geschrieben:Hallo Mischa,

Da hast du wohl eine der neuen scamp versionen gezogen und nicht mehr die alte 1.4.6?

Das die Scamp Version die du verlinkt hast.


Ich hab mich jetzt auf den rocky bezogen... aber egal. Die alte 1.4.6 brauchte die plplot lib nicht, da die dort statisch mit ins ausfuehrbare Programm verlinkt war. Da es jetzt die Version 2 als vorkompiliertes rpm gibt, muss man scamp nicht mehr selbst kompilieren, und daher habe ich saemtliche Hinweise auf die alte Kopie von v1.4.6 entfernt. Plplot ist nun allerdings als Voraussetzung dazugekommen, das steht aber auch gross auf der scamp downloadseite. Ich hab es soeben korrekterweise mit in die Liste der Installationsvoraussetzungen uebernommen. Das hatte ich uebersehen, da die meisten hier im Forum mit der alten 1.4.6 fahren, und die wenigen anderen (bzw. meine Kollegen) welche Scamp selbst kompiliert haben, erfahren genug sind, die fehlende Abhaengigkeit selbst erkennen und beheben zu koennen.

Na, ich hoffe dass jetzt alle Unklarheiten beseitigt sind und es bei jedem laeuft.

Mischa
mischa
Moderator
 
Beiträge: 971
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Großes Problem .....

Beitragvon rhess » Freitag 23. Mai 2014, 22:30

Hallo Mischa,

habe jetzt alles nach deiner Anleitung installiert, jetzt kommt aber eine neue Fehlermeldung bei der Astrometrie mit Scamp (Gui 2.9.2)

> Merging detections...
> Computing global color indices
> Saving image headers...
> Generating group plots...
Requested device png not available

*** PLPLOT ERROR, IMMEDIATE EXIT ***
plSelectDev: Too many tries.
Program aborted


und bei Astrometry.net

File "/usr/lib/pymodules/python2.7/pyfits/core.py", line 2582, in index_of
raise KeyError, 'Keyword %s not found.' % `key`
KeyError: "Keyword 'REMLINEN' not found."
augment-xylist.c:586:backtick Failed to run command: /home/hess/THELI/theli//gui/packages/astrometry/build/bin/removelines.py markarian-003L_1OFC.anet /tmp/tmp.removelines.QJZB4T
ioutils.c:669:run_command_get_outputs Command failed: return value 1
+ /home/hess/THELI/theli//bin/Linux_64//dfits /home/hess/.theli/tmp//markarian-003L_1.wcs
error: cannot open file [/home/hess/.theli/tmp//markarian-003L_1.wcs]


Was könnte jetzt das Problem sein ?

Grüße
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10

Re: Großes Problem .....

Beitragvon mischa » Freitag 23. Mai 2014, 22:49

Hi Rocky,

das astrometry.net Problem kannst du loesen, in dem du pyfits Version neuer als 3.1 installierst. Du hast wahrscheinlich noch eine alte, 2.4.
Probier mal

Code: Alles auswählen
sudo pip install pyfits
.

'pip' meine ich hast du ja, wenn nicht bekommst du es ueber

Code: Alles auswählen
sudo apt-get install python-pip


Zu scamp kann ich wenig sagen, entweder fehlt dir eine libpng library, oder aber du musst plplot selbst installieren und bei der Konfiguration explizit eine png Unterstuetzung angeben. Da hab ich jetzt leider keine Zeit dazu dem selbst nachzugehen (wir warten in Santiago auf die Geburt unseres 2. Babys...) evtl. kann dir der Thomas aka Knickohr hier aushelfen :-)

mischa
mischa
Moderator
 
Beiträge: 971
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Großes Problem .....

Beitragvon rhess » Freitag 23. Mai 2014, 23:14

Hallo Mischa,

wir warten in Santiago auf die Geburt unseres 2. Babys...


Herzlichen Glückwunsch ! Ich wünsche Euch natürlich alles Gute ! :D

Das mit Theli werden wir schon irgendwie hinkriegen :wink:

LG
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10

Re: Großes Problem .....

Beitragvon mischa » Samstag 24. Mai 2014, 00:56

rhess hat geschrieben:Herzlichen Glückwunsch ! Ich wünsche Euch natürlich alles Gute ! :D


Danke, wir sind in guten Haenden :-)
Hab das mit pyfits gerade selbst ausprobiert... da du eine alte Version bereits installiert hast, musst du explizit ein '--upgrade' angeben:

Code: Alles auswählen
sudo pip install pyfits --upgrade


mischa
mischa
Moderator
 
Beiträge: 971
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Großes Problem .....

Beitragvon rhess » Sonntag 25. Mai 2014, 08:18

Hallo Mischa,

Vielen Dank für Deine Hilfe !
Theli läuft jetzt und die Astrometrie funktioniert jetzt auch, allerdings habe ich die alte Scamp Version verwendet (1.4.6), das mit der neuen Version bzw. mit den Paket -
abhängikeiten schaue ich mir später an !
Jedenfalls funktioniert jetzt Theli 1.9.5, Gui 2.9.2 unter Ubuntu 12.04 problemlos ! :D

LG
Rocky
rhess
 
Beiträge: 30
Registriert: Sonntag 9. Oktober 2011, 12:10


Zurück zu Installation und Ubuntheli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste