Theli und Ubuntu 14.04

Linux (Theli bezogen), Theli, GUI und Hilfsprogramme.
Forumsregeln
Bitte die Beiträge kurz fassen, so kann man sie nachher besser finden. Sollte ein Problem gelöst sein, dann einen neuen Beitrag eröffnen. Ebenso wenn die Ursache eine ganz andere ist, oder es Offtopic wird.

Theli und Ubuntu 14.04

Beitragvon frank71 » Samstag 27. Dezember 2014, 19:53

Hallo,
bei mir ist meine alte Festplatte (mit theli) gecrashed und ich versuche, theli unter ubuntu 14.04 neu aufzusetzen. Leider wenig erfolgreich:
Bei mir fangen die Probleme schon bei der QT3-Nachinstallation an. Die unter: http://www.astro.uni-bonn.de/theli/gui/ ... ation.html
genannten repositories funktionieren bei mir in der Einbindung irgendwie nicht.
Die qt3-dev-tools konnte ich mir dann über eine andere Quelle ziehen, allerdings fehlen mir immer noch die qt3-mt-dev Bestandteile. Der weitere Versuch der Installation der python-matplot-Bestandteile führte dann hier zu weiteren Fehlermeldungen und letztendlich lies sich nicht einmal eine theli-executable erstellen.

Sorry,dass ich hier gleich mit einer Anfrage aufschlage, aber könnte mir jemand bei der Installation helfen? Gerne auch über teamviever.

Danke,
Frank
frank71
 
Beiträge: 7
Registriert: Samstag 27. Dezember 2014, 17:16

Re: Theli und Ubuntu 14.04

Beitragvon selste » Sonntag 28. Dezember 2014, 19:15

Hallo Frank,
versuch es doch mal mit den Paketquellen des Tryphon-Projektes ... hat bei mir ohne Probleme funktioniert!
Anleitung findest Du da: http://www.theli-forum.info/viewtopic.php?f=11&t=480
Gruß,

Steffen
selste
 
Beiträge: 110
Registriert: Montag 19. März 2012, 18:39

Re: Theli und Ubuntu 14.04

Beitragvon frank71 » Sonntag 28. Dezember 2014, 21:30

Hallo Steffen,
danke für die Hilfe! Das mit dem Tryphon Projekt hatte ich allerdings zuerst probiert. Habe die zwei Zeilen für trusty in sources.list ergänzt und die Zeile mit dem beschriebenen repository key im terminal ausgeführt. Leider findet er da nicht die notwendigen Dateien (qt3-mt-dev). Muss ich den repository key vielleicht anders ausführen oder "angepasst" ausführen? (Sorry, bin kein linux-Held....).

Danke,
Frank
frank71
 
Beiträge: 7
Registriert: Samstag 27. Dezember 2014, 17:16

Re: Theli und Ubuntu 14.04

Beitragvon selste » Montag 29. Dezember 2014, 14:53

Hi,
das ist merkwürdig - denn in der Paketliste werden die ja explizit aufgeführt.
Kommt irgendeine halbwegs sinnvolle Fehlermeldung, kann z.B. der Repository Key nicht gelesen werden und das Repository somit nicht verifiziert werden?
Gruß,

Steffen
selste
 
Beiträge: 110
Registriert: Montag 19. März 2012, 18:39

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Montag 29. Dezember 2014, 22:03

Hi Frank,
I can help you.
Which architecture has your computer?
32-bit or 64-bit?

On the other hand, you can read my way of installation THELI GUI and SCAMP compilation (for my 64-bit computer!) viewtopic.php?f=12&t=514&start=15#p4291
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Theli und Ubuntu 14.04

Beitragvon frank71 » Dienstag 30. Dezember 2014, 09:11

Hallo,
@Steffen: Ich bekomme nur die Fehlermeldung: nicht gefunden. Ich denke, ich mache da irgendwas in den Pfaden / der Einbindung falsch, weis aber auch nicht was.

@Oleg: I have 64-bit and ubuntu 14.04. I have tried by typing in the commands from your thread. But at section II there start errors: libmng1_1.0..... no access. Maybe that this is due to that I have 14.04, and you did it install on 14.10.

Sorry, Frank
frank71
 
Beiträge: 7
Registriert: Samstag 27. Dezember 2014, 17:16

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Dienstag 30. Dezember 2014, 11:36

frank71 hat geschrieben:Hallo,
@Steffen: Ich bekomme nur die Fehlermeldung: nicht gefunden. Ich denke, ich mache da irgendwas in den Pfaden / der Einbindung falsch, weis aber auch nicht was.

@Oleg: I have 64-bit and ubuntu 14.04. I have tried by typing in the commands from your thread. But at section II there start errors: libmng1_1.0..... no access. Maybe that this is due to that I have 14.04, and you did it install on 14.10.

Sorry, Frank

Ok.
At first, you must download all packages from section II :

Code: Alles auswählen
wget http://de.archive.ubuntu.com/ubuntu/pool/main/libm/libmng/libmng1_1.0.10-3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb


Now, you can install their:

Code: Alles auswählen
sudo dpkg -i libmng1_1.0.10-3_amd64.deb
sudo dpkg -i libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Dienstag 30. Dezember 2014, 11:42

Frank,
I can help you by TeamViewer.

My skype is: astrowiki1
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Dienstag 30. Dezember 2014, 23:51

Sorry, I found the error in my instruction:

Code: Alles auswählen
wget http://de.archive.ubuntu.com/ubuntu/pool/main/libm/libmng/libmng1_1.0.10-3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb

sudo dpkg -i libmng1_1.0.10-3_amd64.deb
sudo dpkg -i libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Theli und Ubuntu 14.04

Beitragvon selste » Mittwoch 31. Dezember 2014, 10:16

Hallo Frank,
bist Du inzwischen einen Schritt vorwärts gekommen, oder gibt es noch Probleme?
TemViewer habe ich momentan zwar nicht installiert, aber da lässt sich ja Abhilfe schaffen bei Bedarf!
Gruß und einen guten Rutsch,

Steffen
selste
 
Beiträge: 110
Registriert: Montag 19. März 2012, 18:39

Re: Theli und Ubuntu 14.04

Beitragvon frank71 » Donnerstag 1. Januar 2015, 19:11

Hello Steffen and Oleg,

a happy New Year!

And: It looks as if the solution is coming nearer: I tried with the last routine from Oleg. In the first run I got error messages of unsolved dependencies and then ubuntu tried to repair software packages. After a reboot and a second try I get at this line the following error:

sudo apt-get install python-matplotlib libplplot11 libgsl0ldbl libgsl0-dev

"Paket libplplot11 ist nicht verfügbar, wird aber von einem anderen Paket referenziert.....
Für Paket libplplot11 existiert kein Installationskandidat."
(libplplot11 is not existent but referenced by a second package. There is no installation candidate for libplplot11)

But the rest of the installation now seems to run through. I get now a theli executable, too. Only problem left: It doesn't start...

Sorry and thanks again for your help! I greatly appeciate it!

Frank
frank71
 
Beiträge: 7
Registriert: Samstag 27. Dezember 2014, 17:16

Re: Theli und Ubuntu 14.04

Beitragvon selste » Donnerstag 1. Januar 2015, 20:42

Hello Frank,
happy new year - glad to hear that the problem with QT3 is resolved.

'libplpot' has been updated, You have to install 'libplplot12' now - the rest of the packages mentioned in the official wiki remain the same.
Cheers,

Steffen
selste
 
Beiträge: 110
Registriert: Montag 19. März 2012, 18:39

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Freitag 2. Januar 2015, 11:42

Hello Frank,
yes, Ubuntu 14.04 needs the libplplot12: see my instruction viewtopic.php?f=12&t=514&start=15#p4291

In any case, THELI GUI don't run without scamp file in /theli-1.9.5/bin/Linux_64/ directory.
Do you compiled the scamp?
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Theli und Ubuntu 14.04

Beitragvon frank71 » Freitag 2. Januar 2015, 19:31

Hello,

theli is now starting and I can work with theli until to the Astronmetry part. Thank you very much!

But now I have a little problem with scamp: In the Astrometry part scamp generates an error: (which I extracted from the rpm-archive) It wanted the libplplotd.so.11 version. This I managed by just copying the 12 to a 11 version file. But then scamp wanted a libqhull.so.5 file. There I didn't find anything comparable. So I was not sucessfull on the "brute force way".

Then I tried by a direct compilation as written by Oleg's thread in the posting just before. I downloaded the scamp-zip file and extracted it. In the scamp directory I executed the configure path as written in Oleg's thread. The answer I get here is many yes statements and one no-statement: aclient_cgi configure errror: not found. A cgs client installation (as descibed here: viewtopic.php?p=2467) didn't help here, too, to get this error message away. Then I wanted to compile via make. I get then only an error message: No target given and no control file. Finish.

Sorry! I am not yet trough. Need help again!

Frank
frank71
 
Beiträge: 7
Registriert: Samstag 27. Dezember 2014, 17:16

Re: Theli und Ubuntu 14.04

Beitragvon oleg » Freitag 2. Januar 2015, 20:16

Hello Frank,

This error "aclient_cgi configure errror: not found." means: scamp don't see the cdsclient files.

You can download and install the cdsclient-3.77 from its source code:
Code: Alles auswählen
wget http://cdsarc.u-strasbg.fr/ftp/pub/sw/cdsclient.tar.gz
tar xzf cdsclient.tar.gz
cd cdsclient-3.77
./configure
make
sudo make install


So, you compiled and installed the cdsclient files.

Now, you can try compile the scamp:
Code: Alles auswählen
cd trunk.r328
./configure --enable-threads=12 --with-cdsclient-dir=/usr/local/bin --with-atlas-libdir=/usr/lib/ --with-atlas-incdir=/usr/include/atlas --enable-plplot --with-plplot-libdir=/usr/lib/plplot5.10.0 --with-plplot-incdir=/usr/include/plplot
make


P.S. Frank, I can help you by TeamViewer.
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Nächste

Zurück zu Installation und Ubuntheli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron