theli 2.10.0 und scamp-2.0.4/scamp-1.4.6

Linux (Theli bezogen), Theli, GUI und Hilfsprogramme.
Forumsregeln
Bitte die Beiträge kurz fassen, so kann man sie nachher besser finden. Sollte ein Problem gelöst sein, dann einen neuen Beitrag eröffnen. Ebenso wenn die Ursache eine ganz andere ist, oder es Offtopic wird.

theli 2.10.0 und scamp-2.0.4/scamp-1.4.6

Beitragvon hajo » Dienstag 12. Januar 2016, 18:02

Hallo liebe Leute,


ich habe meinen Rechner von opensuse 13.2 (32bit) auf suse leap42.1
(64bit) umgezogen und wollte die Gelegenheit nutzen, die neue theli-2.10.0
Version zu installieren (bisher theli-2.9.2). Das hat soweit auch
funktioniert - es gibt aber ein Problem mit scamp. Da die binary version 2.0.4
ein Problem mit der neuem plplot library hat, habe ich scamp-2.0.4 neu kompiliert
was auch funktioniert hat - dank einiger Hinweise hier im Forum. Leider
crasht scamp während der astrometry - bringt sie jedenfalls nicht vollständig
zu Ende:

Calculating astrometric solution ...
Collecting image statistics ...
Collecting information for coaddition ...
ERROR (line 1469): Showing you the log ...

und dort
./create_scamp.sh: line 475: 9829 Segmentation fault

die anschließende coaddition wird verweigert mit

STOP: Coaddition: Not all science images have separate astrometric headers!

Ich habe den forums thread "SCAMP v2.0.4 doesn't work normally in Ubuntu 15.04 (64 bit)"
gelesen, bei mir beschränkt sich das Problem leider nicht darauf, dass scamp keine plots mehr erzeugt, es crasht bereits vorher
(plots verzeichnis leer bis auf das scamp.log)

Das scamp log bricht ab mit:
.....
......
Filling the global astrometry matrix: group 1/1, field 14/15
Filling the global astrometry matrix: group 1/1, field 15/15
Fixing the degrees of freedom
Solving the global astrometry matrix...


Meine Idee wieder auf die alte scamp 1.4.6 Version zurückzugreifen scheint
aber auch nicht zu funktionieren - da bekomme ich Fehlermeldungen über
unbekannte Parameter.

Meine Frage(n): Ist scamp 1.4.6 nicht mehr kompatibel mit theli 2.10.0 - im
change log habe ich darauf keine Hinweise gefunden?

Was kann man tun - ausser auf eine neue scamp version zu hoffen (ältere
scamp versionen kompilieren wieder nicht mit der neuen plplotlib)? Da das
Programm crasht, kann ich doch nicht der einzige Betroffene sein?

Kann man (eventuell mit ein paar script Änderungen) scamp 1.4.6 doch mit theli
2.10.0 laufen lassen?


Hat jemand eine Idee?
Schon mal vielen Dank im Voraus

Grüsse
Hajo
hajo
 
Beiträge: 11
Registriert: Montag 26. März 2012, 17:50

Zurück zu Installation und Ubuntheli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast