Anhaltende Probleme

Wie arbeite ich mit Theli, wie verarbeite ich in Theli erstellten Bilder ?
Forumsregeln
Bitte die Beiträge kurz fassen, so kann man sie nachher besser finden. Sollte ein Problem gelöst sein, dann einen neuen Beitrag eröffnen. Ebenso wenn die Ursache eine ganz andere ist, oder es Offtopic wird.

Anhaltende Probleme

Beitragvon frasax » Dienstag 9. September 2014, 14:04

Hallo Mischa und co.,

ich habe schon seit Monaten immer wieder Probleme. Zum Teil habe ich das hier schon geschrieben, aber aus zeitlichen Gründen immer nur stückweise verfolgt.
Anbei mal ein zip Ordner mit einem Coad, einem RGB und einem Flat.

www.astrophotocologne.de/astrophotocolo ... ispiel.zip

Problem eins ist dieser dunkle Fleck am Bildrand den ich seit neustem in allen Bildern habe. Erklären kann ich mir den nicht, zumal der weder im Flat selber noch im Masterflat noch in irgendeinem weight auftaucht. Auch unterschiedliche Koordinaten für die Skysubtraction brachten keine Verbesserung.

Das andere Problem betrifft die Farbdrift. Das angehängte Bild zeigt deutliche Abweichungen der Farbe ins blaue (rot im Histogramm links, grün in der Mitte, blau rechts). In dem Fall mit Nomad kalibriert, aber bei einem anderen Bild taucht das Problem ebenso auf und das wurde mit SDSS kalibriert.

Ich stehe absolut auf dem Schlauch woher diese Probleme kommen. Es lief all die Jahre ja immer gut.

LG Frank
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon mischa » Dienstag 9. September 2014, 14:47

Welchen dunklen Fleck meinst du? Ich kann nichts auffaelliges in den Bildern erkennen. Und womit kann ich den FITS cube als Farbbild darstellen? Ist der Fleck noch da wenn du einen "constant sky" machst?

mischa
mischa
Moderator
 
Beiträge: 986
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Anhaltende Probleme

Beitragvon frasax » Dienstag 9. September 2014, 16:29

ich meine den dunklen Fleck am rechten kurzen Bildrand. ich habe die das RGB mal als 16bit TIFF in den Ordner gelegt. Da siehst du es vielleicht auch besser.
Constant Sky? Mach ich immer, aber ich schaue gerade mal was passiert wenn ich Model the Sky verwende.


Ach so, den da. Der ist nicht so auffaellig. Wenn er beim 'constant sky' auftaucht, dann kann es eigentlich nur am Flat liegen. Ist er bei anderen Datensaetzen an der gleichen Stelle?

Kleiner Test: Geh ins FLAT verzeichnis, und mach dort

Code: Alles auswählen
cp FLAT_1.fits FLAT_1.fits_backup
fitsflip -i FLAT_1.fits -o bla.fits -r 180
mv bla.fits FLAT_1.fits


Das dreht das Flat um 180 grad. Dann reduzierst du nochmal. Wenn es am Flat liegt, sollte der Fleck an anderer Stelle auftauchen.

Darum habe ich die Flats in Verdacht. Die sehen aber ja OK aus.


Das bedeutet wirklich rein gar nichts ob das Flat "gut" aussieht oder nicht. Du hast uebers gesamte Flat hinweg etwa 8% Helligkeitsschwankungen, entlang des rechten Randes knapp 3%. Wie willst du da z.B. eine Abweichung von absolut 0.5% mit dem blossen Auge erkennen? Die kann dir problemlos so einen Fleck hinzaubern, der dann wunderbar im coaddierten Bild bei hohem S/N sichtbar wird.

mischa
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon frasax » Dienstag 9. September 2014, 16:42

erstaunlicherweise sehen die Ergebnisse exakt gleich aus egal ob ich constant oder model the sky verwende. Das hätte ich jetzt auch nicht gedacht. Da ist so gar kein Unterschied!? Das kann eigentlich nicht sein!?!?


Wieso nicht? Ich deine Parametereinstellungen nicht. Du kannst die Modellierung problemlos so einstellen, dass fast alles maskiert wird, dann wird auch kaum was wegmodelliert...

mischa
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon frasax » Mittwoch 10. September 2014, 14:44

Hi Mischa

Ganz kurz weil unterwegs.
Ok das leuchtet ein, hatte ich mir auch fast so gedacht. Werde das testen.

Aber hast du auch ne Idee wegen der Farben?
LG Frank
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon mischa » Mittwoch 10. September 2014, 15:20

frasax hat geschrieben:Aber hast du auch ne Idee wegen der Farben?


Schick mal ein RGB Tiff damit man sich einen eindruck verschaffen kann.
mischa
Moderator
 
Beiträge: 986
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Anhaltende Probleme

Beitragvon frasax » Mittwoch 10. September 2014, 15:58

Müsste in der Zip Datei sein. Müsstest den Download nochmal machen, da ich das TIFF erst gestern nachträglich hochgeladen habe.

LG Frank
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon mischa » Mittwoch 10. September 2014, 17:06

frasax hat geschrieben:Das andere Problem betrifft die Farbdrift. Das angehängte Bild zeigt deutliche Abweichungen der Farbe ins blaue (rot im Histogramm links, grün in der Mitte, blau rechts). In dem Fall mit Nomad kalibriert, aber bei einem anderen Bild taucht das Problem ebenso auf und das wurde mit SDSS kalibriert.


Das hat nichts mit der Farbkalibration zu tun (die Sterne sehen gut aus!) sondern mit der Hintrergrundsubtraktion. Da hast du halt im Blaukanal vergleichsweise weniger abgezogen als im Rot/Gruenkanal. Probier mal eine andere Stelle fuer den constant-sky aus.

mischa
mischa
Moderator
 
Beiträge: 986
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Anhaltende Probleme

Beitragvon frasax » Mittwoch 10. September 2014, 20:04

Hi Mischa,

danke für deine Antworten. Das hilft mir doch etwas weiter. Ich werde bei Gelegenheit neue Flats machen und es noch einmal versuchen.

Nur als Gedankenexperiment: Könnte neben der Skysubtraction auch die unterschiedliche Qualität der Farbkanäle die Ursache für die Farbverschiebung zu sein? Der Rotkanal ist aus Namibia, mit passenden Flats. Grün und Blau sind recht aktuell aus Teneriffa mit vermutlich nicht sehr gut passenden Flats?

LG Frank
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln

Re: Anhaltende Probleme

Beitragvon mischa » Mittwoch 10. September 2014, 21:05

frasax hat geschrieben:Nur als Gedankenexperiment: Könnte neben der Skysubtraction auch die unterschiedliche Qualität der Farbkanäle die Ursache für die Farbverschiebung zu sein? Der Rotkanal ist aus Namibia, mit passenden Flats. Grün und Blau sind recht aktuell aus Teneriffa mit vermutlich nicht sehr gut passenden Flats?

LG Frank


Ich glaube weder das eine noch das andere. Da musst du die flats schon ordentlich versaut haben.

mischa
mischa
Moderator
 
Beiträge: 986
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Anhaltende Probleme

Beitragvon frasax » Mittwoch 10. September 2014, 21:56

Hallo Mischa,

ich werde der Sache weiter auf den Grund gehen.
Deine Antworten beruhigen/ermutigen mich aber etwas, da ich schon befürchtet hatte das 5 komplette Nächte Teneriffa für den Müll waren.

LG Frank
Ich will Feuerwehrmann werden!!!!!
----------------------------------------------
http://www.astrophotocologne.de
http://www.youtube.com/astrophotocologne
http://www.facebook.com/astrophotocologne
Benutzeravatar
frasax
Grisu, der kleine Drache
 
Beiträge: 379
Registriert: Montag 3. Oktober 2011, 00:28
Wohnort: Köln


Zurück zu Arbeiten mit Theli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron