Who can write the instruction for scamp compilation?

Wie arbeite ich mit Theli, wie verarbeite ich in Theli erstellten Bilder ?
Forumsregeln
Bitte die Beiträge kurz fassen, so kann man sie nachher besser finden. Sollte ein Problem gelöst sein, dann einen neuen Beitrag eröffnen. Ebenso wenn die Ursache eine ganz andere ist, oder es Offtopic wird.

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Samstag 6. Dezember 2014, 16:59

mischa hat geschrieben:
Knickohr hat geschrieben:[
Disable your CPU-throttle !


Under Ubuntu I do this as follows:

Code: Alles auswählen
cpufreq-info
to list the throttling states and availbale frequencies...

Code: Alles auswählen
cpufreq-set -g performance


Verify with 'cpufreq-info' that the setting has been applied.

mischa

Many thanks!
Yes, I found it:
Code: Alles auswählen
oleh@oleh:~$ sudo cpufreq-info
[sudo] password for oleh:
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 5.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 5.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.30 GHz (asserted by call to hardware).
analyzing CPU 1:
...
...
...
analyzing CPU 11:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 11
  CPUs which need to have their frequency coordinated by software: 11
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 5.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 5.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.30 GHz (asserted by call to hardware).
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Samstag 6. Dezember 2014, 17:53

I don't understand it...

All my SCAMP and SCAMP from Emmanuel Bertin (http://www.astromatic.net/download/scam ... x86_64.rpm) don't work correctly:

Code: Alles auswählen
> Merging detections...
> Computing global color indices
> Saving image headers...
> Generating group plots...
Requested device png not available

*** PLPLOT ERROR, IMMEDIATE EXIT ***
plSelectDev: Too many tries.
Program aborted
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Who can write the instruction for scamp compilation?

Beitragvon Knickohr » Samstag 6. Dezember 2014, 18:02

Look : requested device png not available

Haye you installed the libplplot-dev and libraries for png ?

see other post in this forum :
viewtopic.php?f=13&t=237

von Tobias » Mi 11 Jul, 2012 23:24
- zum Thema ""too many tries" + es gibt keine Plots mehr" : bei mir hat es geholfen die "libs" nach zu installieren welche Ubuntu anbietet, wenn man nach "png plplot" sucht


Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 623
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Samstag 6. Dezember 2014, 18:24

Hurra! SCAMP works correctly!
How I fix my problem with the "Requested device png not available"?

I installed the plplot12-driver-gd.

To Mischa: please, add this package note in instruction 2.1. Software pre-requisites http://www.astro.uni-bonn.de/theli/gui/ ... ation.html

Code: Alles auswählen
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install csh g++ gawk wget build-essential libqt3-mt-dev
sudo apt-get install python python-dev python-numpy python-scipy libbz2-dev
sudo apt-get install python-matplotlib libplplot11 libgsl0ldbl libgsl0-dev
sudo apt-get install libfftw3-dev libtiff4-dev imagemagick libpng3 libccfits-dev
sudo apt-get install python-pip
sudo pip install astropy pyfits
Zuletzt geändert von oleg am Samstag 6. Dezember 2014, 19:00, insgesamt 1-mal geändert.
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Samstag 6. Dezember 2014, 18:58

I created two worked versions of SCAMP:

1. v.1 has weight 6.3MB

Code: Alles auswählen
cd /home/oleh/trunk.r328
./configure --enable-threads=12 --with-cdsclient-dir=/usr/local/bin --with-atlas-libdir=/usr/local/atlas/lib/ --with-atlas-incdir=/usr/local/atlas/include
make


2. v.2 has weight 2.1MB

Code: Alles auswählen
cd /home/oleh/trunk.r328
./configure --enable-threads=12 --with-cdsclient-dir=/usr/local/bin --with-atlas-libdir=/usr/lib/ --with-atlas-incdir=/usr/include/atlas --enable-plplot --with-plplot-libdir=/usr/lib/plplot5.10.0 --with-plplot-incdir=/usr/include/plplot
make
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Dienstag 9. Dezember 2014, 15:53

So, you can reed my way of THILI GUI and SCAMP compilation and installation on fresh installed OS Ubuntu 14.10 64-bit:

I. At first, I added several packages to instruction from page 2.1. Software pre-requisites http://www.astro.uni-bonn.de/theli/gui/ ... ation.html:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install csh g++ gawk wget build-essential libqt3-mt-dev
sudo apt-get install python python-dev python-numpy python-scipy libbz2-dev
sudo apt-get install python-matplotlib libplplot12 libgsl0ldbl libgsl0-dev
sudo apt-get install libfftw3-dev libtiff5-dev imagemagick libpng3 libccfits-dev
sudo apt-get install plplot12-driver-gd libplplot-dev libatlas-dev libatlas3-base libatlas-base-dev
sudo apt-get install python-pip
sudo pip install astropy pyfits
sudo apt-get install liblcms1

II. I downloaded and installed these packages:
sudo dpkg -i libmng1_1.0.10-3build1_amd64.deb
sudo dpkg -i libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb

III. I downloaded and installed the cdsclient-3.77 from its source code:
cd /home/oleh/cdsclient-3.77cd
./configure
make
sudo make install

IV. I downloaded and installed the last version of SCAMP (warning!) without previous compilation of ATLAS from its source code:
cd /home/oleh/trunk.r328
./configure --enable-threads=12 --with-cdsclient-dir=/usr/local/bin --with-atlas-libdir=/usr/lib/ --with-atlas-incdir=/usr/include/atlas --enable-plplot --with-plplot-libdir=/usr/lib/plplot5.10.0 --with-plplot-incdir=/usr/include/plplot
make
cd src
cp scamp /home/oleh/Theli/theli-1.9.5/bin/Linux_64
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Re: Who can write the instruction for scamp compilation?

Beitragvon mischa » Dienstag 9. Dezember 2014, 19:57

oleg hat geschrieben:III. I downloaded and installed the cdsclient-3.77 from its source code


The cdsclient isn't necessary. It is already bundled with the THELI GUI package. The scamp configure script might want to see it though when compiling from source.

mischa
mischa
Moderator
 
Beiträge: 987
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Who can write the instruction for scamp compilation?

Beitragvon oleg » Mittwoch 10. Dezember 2014, 00:14

mischa hat geschrieben:
oleg hat geschrieben:III. I downloaded and installed the cdsclient-3.77 from its source code


The cdsclient isn't necessary. It is already bundled with the THELI GUI package. The scamp configure script might want to see it though when compiling from source.

mischa

Yes, you are right. Many thanks!

So, you can read about my way of THELI GUI and SCAMP compilation and installation on fresh installed OS Ubuntu 14.10 64-bit:

I. At first, I added several packages to instruction from page 2.1. Software pre-requisites http://www.astro.uni-bonn.de/theli/gui/ ... ation.html:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install csh g++ gawk wget build-essential
sudo apt-get install python python-dev python-numpy python-scipy libbz2-dev
sudo apt-get install python-matplotlib libplplot12 libgsl0ldbl libgsl0-dev
sudo apt-get install libfftw3-dev libtiff5-dev imagemagick libpng3 libccfits-dev
sudo apt-get install plplot12-driver-gd libplplot-dev libatlas-dev libatlas3-base libatlas-base-dev
sudo apt-get install python-pip
sudo pip install astropy pyfits
sudo apt-get install liblcms1

II. I downloaded and installed these packages:
sudo dpkg -i libmng1_1.0.10-3build1_amd64.deb
sudo dpkg -i libqt3-headers_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i qt3-dev-tools_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i libqt3-mt-dev_3.3.8-b-8ubuntu3_amd64.deb

III. I downloaded and installed the last version of SCAMP (warning!) without previous compilation of ATLAS from its source code:
cd /home/oleh/trunk.r328
./configure --enable-threads=12 --with-cdsclient-dir=/home/oleh/Theli/theli-1.9.5/bin/Linux_64 --with-atlas-libdir=/usr/lib/ --with-atlas-incdir=/usr/include/atlas --enable-plplot --with-plplot-libdir=/usr/lib/plplot5.10.0 --with-plplot-incdir=/usr/include/plplot
make
cd src
cp scamp /home/oleh/Theli/theli-1.9.5/bin/Linux_64
Ubuntu 14.04 64-bit (CPU Intel® Core™ i7-3930K, RAM 64GB, RAID0: 6x1TB).
oleg
 
Beiträge: 85
Registriert: Samstag 1. Oktober 2011, 18:00
Wohnort: Portugal

Vorherige

Zurück zu Arbeiten mit Theli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron