Neueste scamp-Version installieren

Tipps & Tricks rund um Theli, kleine Helferlein, bekannte Probleme und deren Lösung.
Forumsregeln
In diesem Unterforum bitte keine neuen ungelösten Probleme oder Fehlermeldungen ohne Lösung posten. Das gehört in "Arbeiten mit Theli".

Neueste scamp-Version installieren

Beitragvon Knickohr » Samstag 31. März 2012, 19:19

Hallo,

ein mal etwas Hardcore-Linux-ToDo :

Wie installiere ich die aktuelle scamp-Version ?

Warum das Ganze ?

Nun, ich hatte Probleme bei meinen vielen tausend Bildern, eine astrometrische Lösung zu bekommen. Das lag nicht daran, das die Daten schlecht waren oder die Astrometrie nicht geklappt hat, sondern das ich an ein Limit von scamp gestoßen bin. Offensichtlich verkraftet scamp nicht mehr wie 3300 Images bzw. Kataloge. Eine weitere Integer, 2GB-Grenze. Die neue Version von Scamp hat das Problem nicht mehr.

Als erstes downloaden wir uns mal die folgenden Tarfiles :

- atlas
http://sourceforge.net/projects/math-at ... ble/3.8.4/

- cdsclient
http://cdsweb.u-strasbg.fr/doc/cdsclient.html

- scamp
http://www.astromatic.net/wsvn/public/d ... =0&isdir=1

PC vorbereiten :

- entpacken der obigen Tarfiles in einen Ordner. Ich habe das unter ~/THELI gemacht.
- CPU-Thtottling abschalten :shock: Wie geht das ? Ganz einfach. Entweder über das BIOS oder aber über die grafische Oberfläche, falls ihr die Prozessor-Überwachungs-Addons in dem Gnome-Panel installiert habt.
- das Paket libplplot-dev über das Ubuntu Software-Center nachinstallieren
- Konsole öffnen
- sich als root anmelden oder root werden (sudo su - root)

Los gehts :

# cd /home/theli/THELI/cdsclient-3.6
# ./configure
# make
# make install

# cd /home/theli/THELI/ATLAS
# mkdir MyObj (ist nötig, da es sonst abbricht !)
# cd MyObj
# /home/theli/THELI/ATLAS/configure -b 64 (64 steht für 64bit, bei 32bit 32 angeben)
# make
# make check
# make ptcheck
# make time
# make install

# cd /home/theli/THELI/trunk.r283
# ./configure --enable-threads
# make
# make install

Die neue scamp-Version befindet sich jetzt in /usr/local/bin und muß ins Theli-Verzeichnis kopiert werden :

# cp /usr/local/bin/scamp /home/theli/THELI/theli-1.6.1/bin/Linux_64/

Nun könnt ihr euch als root abmelden und testen :

# scamp

theli@theli:~$ scamp

SCAMP version 1.12.2 (2012-03-31)

:-)

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Schicko » Donnerstag 7. Juni 2012, 11:25

Servus Thomas,

vielen Dank für die detaillierte Anleitung!

Die Installation funktioniert auch reibungslos, aber hinterher gibt's leider keine Plots mehr.
Der entsprechende Auszug aus dem Errorlog:
Code: Alles auswählen
> Making preliminary cross-identifications in group 1
> Generating group plots...
Requested device png not available

*** PLPLOT ERROR, IMMEDIATE EXIT ***
plSelectDev: Too many tries.
Program aborted

Plotting Options:
< 1> ps         PostScript File (monochrome)
< 2> psc        PostScript File (color)
< 3> xfig       Fig file
< 4> null       Null device
< 5> mem        User-supplied memory device
< 6> svg        Scalable Vector Graphics (SVG 1.1)

Enter device number or keyword:
Invalid device: 


libplplot-dev ist installiert und wird auch vom Scamp configure erkannt:
Code: Alles auswählen
checking PLPlot configure options... yes
checking for PLPlot pkg-config info... yes


Tja, welchen Schalter muss ich noch umlegen?
Schicko
 
Beiträge: 32
Registriert: Mittwoch 12. Oktober 2011, 08:16
Wohnort: Erlangen

Re: Neueste scamp-Version installieren

Beitragvon mischa » Donnerstag 7. Juni 2012, 13:09

hi schicko,

versuch mal libgd-dev ueber das repository zu installieren, dann scamp bzw plplot nochmal neu kompilieren.

mischa
mischa
Moderator
 
Beiträge: 984
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Neueste scamp-Version installieren

Beitragvon Knickohr » Donnerstag 7. Juni 2012, 13:41

Hab ich hier geschrieben :

Knickohr hat geschrieben:PC vorbereiten :

- entpacken der obigen Tarfiles in einen Ordner. Ich habe das unter ~/THELI gemacht.
- CPU-Thtottling abschalten :shock: Wie geht das ? Ganz einfach. Entweder über das BIOS oder aber über die grafische Oberfläche, falls ihr die Prozessor-Überwachungs-Addons in dem Gnome-Panel installiert habt.
- das Paket libplplot-dev über das Ubuntu Software-Center nachinstallieren
- Konsole öffnen
- sich als root anmelden oder root werden (sudo su - root)

Bei mir war dann das Paket mit dabei, bzw. es gab eine Abhängigkeit ;-)

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Schicko » Donnerstag 7. Juni 2012, 19:16

@Thomas:
"- das Paket libplplot-dev über das Ubuntu Software-Center nachinstallieren"
Genau das hab ich ja gemacht.

@Mischa:
libgd-dev finde ich nicht, meinst du vielleicht libgd2-xpm-dev oder libgd2-noxpm-dev?
Schicko
 
Beiträge: 32
Registriert: Mittwoch 12. Oktober 2011, 08:16
Wohnort: Erlangen

Re: Neueste scamp-Version installieren

Beitragvon mischa » Donnerstag 7. Juni 2012, 19:20

Schicko hat geschrieben:libgd-dev finde ich nicht, meinst du vielleicht libgd2-xpm-dev oder libgd2-noxpm-dev?


ja, genau die.

mischa
mischa
Moderator
 
Beiträge: 984
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Neueste scamp-Version installieren

Beitragvon Knickohr » Donnerstag 7. Juni 2012, 23:00

Nun ja,

bei mir hat er anfangs auch keine Plots gemacht. Dann habe ich temporär auf das SVG-Format umgestellt. Aber nachdem mischa (oder wars Carsten ?) mir den Tip mit den Libraries gegeben hat, gings wieder. Bei mir waren wohl schon ein paar mehr LIBs vorhanden. Anyway, übrigens irgendwo in irgend so einem Log steht sicher, was ihm weh tut und was er will. Linux halt ;-)

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Schicko » Freitag 8. Juni 2012, 09:12

Servus Leute,

jetzt tut's - ich weiß nur nicht warum ...
Installieren der Lib libgd2-xpm-dev (und neu compilieren von Scamp) hat erstmal nichts gebracht, dann hab ich das plplot und die Lib wieder deinstalliert und dann wahrscheinlich (war schon spät) zuerst libgd2-xpm-dev und dann libplplot-dev installiert, vielleicht lag's einfach an der Reihenfolge.

Jedenfalls interessant der Vergleich Neu-Alt:
Code: Alles auswählen
SCAMP 1.14.2 started on 2012-06-08 at 01:06:04 with 4 threads (run time: 54 min 11 s)

Nfields     Alpha           Delta           Pixel Scale     Internal Astrometric Sigma     Internal Astrometric Correlation     Internal χ2     Detections for internal statistics
282         10:03:34.00     +72:54:19.0     11.6269¨        1.8982¨      1.8806¨           0.01265                              12.6            2151093


Code: Alles auswählen
SCAMP 1.4.6-MP started on 2012-06-08 at 09:42:26 with 4 threads (run time: 1 h 12 min)

Nfields     Alpha           Delta           Pixel Scale     Internal Astrometric Sigma     Internal Astrometric Correlation     Internal χ2     Detections for internal statistics
282         10:03:34.00     +72:54:19.0     11.6269¨        2.1594¨      2.1464¨           0.01376                              24.3            2192545


Scheint so, als ob die neue Version nicht nur schneller rechnet, sondern auch eine bessere Lösung findet!
Schicko
 
Beiträge: 32
Registriert: Mittwoch 12. Oktober 2011, 08:16
Wohnort: Erlangen

Re: Neueste scamp-Version installieren

Beitragvon Knickohr » Samstag 9. Juni 2012, 17:09

Schicko hat geschrieben:Scheint so, als ob die neue Version nicht nur schneller rechnet, sondern auch eine bessere Lösung findet!

Das ist interessant ! An sowas habe ich nicht gedacht. Bei mir war es mehr ein Muß, weil ich sonst meine Milchstraßenpanoramen in den Gulli kicken hätte können

Naja, es gibt auch einen Pferdefuß :
Die Plots erstellen dauert eeewiiiiggg ...

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Tobias » Sonntag 10. Juni 2012, 16:20

Hallo zusammen,
da ich ein paar Probleme habe, für meine Lights eine gescheite Astrometrie hinzu bekommen habe ich gedacht, es könnte nicht schaden, es mal mit der aktuellen Version von Scamp zu versuche... leider scheitere ich jedoch schon beim kompilieren.
Ich bin exakt nach oben gegebener Anleitung vorgegangen, allerdings sind zwei der Archive schon in einer aktuelleren Version verfügbar und ich finde von einem Archiv auch nicht mehr die ältere (trunk.r283 ist die Version die ich nicht finden konnte).
Alles scheint bis zum letzten "make" fehlerfrei durch zulaufen, dann jedoch kommt eine Meldung, aus der ich nicht schlau werde, da ich scheinbar die richtige Version installiert habe. Ich hoffe ihr könnt mir da weiter helfen (anbei ein Screenshot).

Vielen Dank für eure Mühe und
CS Tobias
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Tobias
 
Beiträge: 38
Registriert: Samstag 7. April 2012, 17:07

Re: Neueste scamp-Version installieren

Beitragvon Knickohr » Sonntag 10. Juni 2012, 16:33

Hi,

Du mußt die libtool 2.4 drauf machen.

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Tobias » Sonntag 10. Juni 2012, 17:02

Hallo Thomas,
danke für die schnelle Antwort!
Ich habe mir von hier die Libtool 2.4 installiert und es danach vom dritten cd ...trunk.r289 an nochmals probiert, leider ohne Erfolg... (sieh Anhang).
Was mache ich falsch bzw. übersehe ich?

CS Tobias
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Tobias
 
Beiträge: 38
Registriert: Samstag 7. April 2012, 17:07

Re: Neueste scamp-Version installieren

Beitragvon Knickohr » Sonntag 10. Juni 2012, 17:12

Es ist immer noch der gleiche Fehler.

Versuche mal die anderen 3 Libs auch upzudaten.

Warum machst Du das nicht über das Softwarecenter ?

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 622
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Neueste scamp-Version installieren

Beitragvon Tobias » Sonntag 10. Juni 2012, 17:32

Das es noch der gleiche Fehler ist, sehe ich... mit dem Softwarecenter komme ich so gar nicht klar (da sehe ich ja nicht mal die Version....) Ich wollte die anderen beiden Dateien auch noch aktualisieren, jedoch verweigert er es mir immer, da er die jeweils andere als unerfüllbare Abhängigkeit erkennt :cry: .... jetzt weiß ich gar nicht mehr weiter.
Kann mir jemand eine fertig kompilierte Scamp 64bit Version online stellen? (Oder funktioniert das nicht so, wie das in dem Theli-Installations HowTo stehenden Link für die scamp-Datei funktioniert, da es dort eine besondere Version der Kompilierung ist?)
Andere Sache: Verstehe ich denn den Fehler falsch? Für mich steht da, dass ich die Version 2.4 habe, er aber die 2.2.6b erwartet und das war ja def nicht der Fall !?

Dank für die Hilfe und die damit verbundene Mühe
CS Tobias
Tobias
 
Beiträge: 38
Registriert: Samstag 7. April 2012, 17:07

Re: Neueste scamp-Version installieren

Beitragvon Tobias » Mittwoch 11. Juli 2012, 22:24

Hallo zusammen,
leider habe ich von euch nichts mehr gehört, dennoch kann ein paar Neuigkeiten berichten:
- bei dem Versuch die beiden "libs" gleichzeitig zu aktualisieren habe ich mir das gesamte System zerschossen :( (nicht weiter tragisch, nur als Warnung) , da er meinte er müsse auch sämtliche anderen Pakete aus der nun neuen Quelle aktualisieren...
- es wird def. die Version 2.2.6b benötig; nicht die 2.4 !
- leider habe ich es dennoch bis jetzt nicht geschafft scamp einmal komplett ohne Fehler zu kompilieren; das hat netterweise ein Vereinskollege für mich erledigt und mir die Version zugeschickt (funktioniert auch problemlos). Falls jemand ebenfalls ähnliche Probleme hat, kann ich gerne "meine" Version zur Verfügung stellen (64bit Intel Core2Duo).
- zum Thema ""too many tries" + es gibt keine Plots mehr" : bei mir hat es geholfen die "libs" nach zu installieren welche Ubuntu anbietet, wenn man nach "png plplot" sucht

Es folgt jedoch die Ernüchterung: jetzt läuft zwar die neuste Scamp Version , eine richtige astrometrische Lösung finde er immer noch nicht.... hier sitzt wohl der Fehler hinter dem Bildschirm (werde wohl weiter nach den passenden Parametern suchen müssen :x )

CS Tobias
Tobias
 
Beiträge: 38
Registriert: Samstag 7. April 2012, 17:07

Nächste

Zurück zu Tipps und Tricks, FAQ

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast