Download link fuer THELI v3

Linux (Theli bezogen), Theli, GUI und Hilfsprogramme.

Re: Download link fuer THELI v3

Beitragvon mischa » Freitag 27. März 2020, 21:42

Hi Karsten,

d.h. du hast auch versucht, DSLR Daten einzulesen?
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon spiegelei » Freitag 27. März 2020, 21:59

Hallo Mischa,
nein. Das waren normale FITS-Dateien von der Atik.
Gruß
Karsten
Atik 383 - AP80/560 - GSO RC 8" - LX50 8" SC - TSAPO65Q - CGEM
Theli 3 - SUSE Leap 15.1/64 - Dual XEON 12K/24T - 32GB
Die meisten großen Erfindungen beginnen nicht mit "HEUREKA" sondern mit "Das ist aber komisch....."
Benutzeravatar
spiegelei
 
Beiträge: 197
Registriert: Donnerstag 29. September 2011, 15:15
Wohnort: Chemnitz

Re: Download link fuer THELI v3

Beitragvon mischa » Freitag 27. März 2020, 22:21

Hi Karsten,

Und bei was stuerzt er da genau ab? Welche Version hast du dir aus dem repository geladen?
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon spiegelei » Sonntag 29. März 2020, 09:52

Hallo Mischa,

die Abstürze (Speicherzugriffsfehler) treten beim Splitting auf, manchmal gleich nach dem Klick auf Start, manchmal verarbeitet Theli auch eine Reihe von Dateien und bricht dann ab. Mit dem DDD bin ich bis zur splitter.cc gekommen, dann war erst mal Feierabend.

Die meisten Sachen habe ich aus den Quellen neu gebaut (sonst hat sich Atlas nicht übersetzen lassen), sind jeweils auch ziemlich aktuelle Versionen. Ich habe mal mit ldd die SuSe- und Ubuntu-Version von Theli verglichen, bis auf marginale Unterschiede waren die gelinkten Bibliotheken gleich.

Gruß
Karsten
Atik 383 - AP80/560 - GSO RC 8" - LX50 8" SC - TSAPO65Q - CGEM
Theli 3 - SUSE Leap 15.1/64 - Dual XEON 12K/24T - 32GB
Die meisten großen Erfindungen beginnen nicht mit "HEUREKA" sondern mit "Das ist aber komisch....."
Benutzeravatar
spiegelei
 
Beiträge: 197
Registriert: Donnerstag 29. September 2011, 15:15
Wohnort: Chemnitz

Re: Download link fuer THELI v3

Beitragvon mischa » Sonntag 29. März 2020, 10:54

Hi Karsten,

Mit wie vielen Prozessoren laesst du das laufen? Kannst du mir mal ein paar der Bilder hochladen?

mischa
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon spiegelei » Sonntag 29. März 2020, 11:06

Hallo Mischa,
Sytem ist ein Dual-Xeon mit 2x6 Kernen und insgesamt 24 Threads. Der VM mit Ubuntu sind nur 8 Kerne zugewiesen.
Bilder erst wieder kommendes WE (wenn überhaupt, mal sehen, wie die allgemeine Lage ist, ob ich wieder fahren kann...). Hier vor Ort habe ich aktuell keine Möglichkeit ein Testsystem aufzusetzen.


/Edit

Was für Bilder willst Du haben?

Gruß
Karsten
Atik 383 - AP80/560 - GSO RC 8" - LX50 8" SC - TSAPO65Q - CGEM
Theli 3 - SUSE Leap 15.1/64 - Dual XEON 12K/24T - 32GB
Die meisten großen Erfindungen beginnen nicht mit "HEUREKA" sondern mit "Das ist aber komisch....."
Benutzeravatar
spiegelei
 
Beiträge: 197
Registriert: Donnerstag 29. September 2011, 15:15
Wohnort: Chemnitz

Re: Download link fuer THELI v3

Beitragvon mischa » Sonntag 29. März 2020, 12:45

Ich brauch ein oder mehrere Bilder aus dem Datensatz, bei dessen Verarbeitung THELI abstuerzt. Welches (bias, dark, flat, etc) ist egal.

Das heisst, du kannst momentan nicht auf den rechner zugreifen, wo die Bilder liegen, und auch THELI aktuell nicht ausfuehren? Oder hast du remote Zugriff? In letzterem Fall wuerde ich dich bitten, auf der Maschine auf der THELI v3 laeuft, zusaetzlich zu Qt5 noch Qt Creator zu installieren, unter ubuntu z.b. mit 'sudo apt install qtcreator'. Dann koennen wir eine kurze Video-conf machen, und ich schau mir mit dem debugger an, wo das Problem auftritt falls ich es bei mir nicht reproduzieren kann.


mischa
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon spiegelei » Sonntag 29. März 2020, 14:21

Hallo Mischa,
genau ;) Der steht in meiner "Aussenstelle" auf dem Dorf.
Remotezugriff habe ich nicht.
Bild habe ich aber trotzdem, Download unter
www.ekf-mueller.de/misc/M45.zip
Das ist ein Fits, so wie es meine Software ausgibt. Geht unter dem vorigen Theli unter Suse ohne Probleme, unter Ubuntu auch.
Gruß
Karsten
Atik 383 - AP80/560 - GSO RC 8" - LX50 8" SC - TSAPO65Q - CGEM
Theli 3 - SUSE Leap 15.1/64 - Dual XEON 12K/24T - 32GB
Die meisten großen Erfindungen beginnen nicht mit "HEUREKA" sondern mit "Das ist aber komisch....."
Benutzeravatar
spiegelei
 
Beiträge: 197
Registriert: Donnerstag 29. September 2011, 15:15
Wohnort: Chemnitz

Re: Download link fuer THELI v3

Beitragvon mischa » Sonntag 29. März 2020, 15:21

Hi Karsten,

bei mir gehts. Schick mir mal deine kamera.ini Datei, die findest du unter ~/.theli/instruments_user/

mischa
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon spiegelei » Sonntag 29. März 2020, 17:02

Hallo Mischa,
da habe ich die aus der Theli 1.xx genommen. Falls Theli 3 da nix ändert kann ich Dir die schicken, sons müssen wir erst mal warten.

Gruß
Karsten
Atik 383 - AP80/560 - GSO RC 8" - LX50 8" SC - TSAPO65Q - CGEM
Theli 3 - SUSE Leap 15.1/64 - Dual XEON 12K/24T - 32GB
Die meisten großen Erfindungen beginnen nicht mit "HEUREKA" sondern mit "Das ist aber komisch....."
Benutzeravatar
spiegelei
 
Beiträge: 197
Registriert: Donnerstag 29. September 2011, 15:15
Wohnort: Chemnitz

Re: Download link fuer THELI v3

Beitragvon mischa » Sonntag 29. März 2020, 18:00

Hallo Karsten,

da solltest du die neue aus v3 nehmen. ich hab dir mal meine version fuer deine Kamera angehaengt. Probier's mal damit. Du musst nur die dateiendung von.txt auf .ini umstellen. das Forum erlaubt keine Dateien mit .ini Suffix

mischa
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon ThomasS » Sonntag 29. März 2020, 18:24

Hallo Mischa,
ich erreiche dich gerade nicht per Email (wohl ein t-online-Problem), daher der Versuch, dich hier zu kontaktieren.

Ich habe, wie von mir geplant, die Maschine komplett neu aufgesetzt und jetzt funktioniert THELIv3 für CR2s, zumindest erhalte ich jetzt fits.

Im einzelnen: Die Beiträge im Forum waren alle sehr hilfreich, die Installationsbeschreibung für Ubuntu 20 ist fast völlig bei Ubuntu 18 zu verwenden. Wichtig war es auch, die Meldungen im Terminal zu beachten.
Ich musste autoconf-2.69 und automake-1.16, m4-1.4.18, wcslib-7.2 inklusive wcslib-dev und LibRaw-0.19.5 nachinstallieren trotz der Durchführung deiner sudo apt install g++ build-essential autotools... ganz zu Anfang.
Außerdem sagt apt show scamp am Ende immer noch Version 2.0.4+dsfg-1, bei swarp und sextractor wird dagegen die von dir angegebene devel-Version angezeigt.

Eine richtige Ursache für die Probleme vor der Neuinstallation konnte ich nicht feststellen.
Danke für die viele Mühe.
Thomas
ThomasS
 
Beiträge: 29
Registriert: Dienstag 24. März 2020, 20:57
Wohnort: Surberg

Re: Download link fuer THELI v3

Beitragvon mischa » Sonntag 29. März 2020, 19:41

Hi Thomas,

mit 'apt show scamp' zeigst du nur das an, was du auch mit 'apt' installiert hast. 'apt' weiss nichts von deiner manuellen Installation. Da musst du nach scamp/src/ gehen und dort direkt "./scamp -v" aufrufen. Wenn das geht, dann loeschst du die alte scamp version:

sudo apt remove scamp

und kopierst die neue Datei nach /usr/bin/scamp
mischa
Moderator
 
Beiträge: 1205
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Download link fuer THELI v3

Beitragvon Knickohr » Freitag 4. September 2020, 11:00

Der Downloadlink ist jetzt auch über den Drachen (links oben im Forum) erreichbar.

Thomas
Benutzeravatar
Knickohr
Moderator
 
Beiträge: 628
Registriert: Donnerstag 29. September 2011, 12:01
Wohnort: Blaustein

Re: Download link fuer THELI v3

Beitragvon Nobse » Freitag 11. September 2020, 17:08

Hallo zusammen,

ich wollte mir auch die V3 installieren und bleibe aber immer bei dem Fehler mit "'SensorTemperature'/'CameraTemperature'" hängen.
Ich habe mir von dieser Seite "https://www.libraw.org" die neuste libraw 0.20 geholt und nach der Anleitung installiert.
Muss ich noch mehr machen oder wurde die Version 0.20 nicht richtig installiert, fehlen Pfade.
Habe schon alles probiert über Neustart, mehrmals installiert aber komme nicht weiter.
Falls jemand Tipps hat schon mal Danke im Voraus!
Gruß
Norbert
Nobse
 
Beiträge: 8
Registriert: Mittwoch 30. Januar 2013, 22:11

VorherigeNächste

Zurück zu Installation

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron