Seite 12 von 12

Re: Bug Report Theli v3

BeitragVerfasst: Sonntag 18. Oktober 2020, 12:47
von eisentpferd
Hallo Mischa,
das Speicherproblem besteht auch an 2 weiteren Stellen:
Nach der Astrometrie wenn ich "accept" klicke. Dann läd er wohl nochmal alle Bilder und platzt.
Und bei der skysubstraction (constant sky). Nach der Meldung "Measuring sky level in user-defined areas" läd er alle Bilder nochmal und platzt bei 24GB.

In beiden Fällen spielt es keine Rolle was ich bei "max usable memory" in den Einstellungen angebe.

Nur mit "minimize memory usage" zähmt den Speicherhunger und Theli bleibt am Leben.

Eigentlich will ich ja so viel performance haben wie möglich. Mich stört ja schon dass scamp an den 150 Bildern 40min rumrechnet. Ich muss mal testen ob scamp 2.9 da besser ist (wenn ich es gebaut bekomme).

Aber "minimize memory usage" ist ja erstmal eine Lösung.

Danke /Hendrik/

Re: Bug Report Theli v3

BeitragVerfasst: Samstag 7. November 2020, 17:58
von dietmar
Moin Mischa,

wenn Theli sich sang- und klanglos verabschiedet, wenn vergessen hat was einzutragen ist das unschön :).

Viel Spaß noch,
Dietmar

Re: Bug Report Theli v3

BeitragVerfasst: Sonntag 8. November 2020, 11:43
von mischa
dietmar hat geschrieben:Moin Mischa,

wenn Theli sich sang- und klanglos verabschiedet, wenn vergessen hat was einzutragen ist das unschön :).

Viel Spaß noch,
Dietmar


"wenn vergessen hat was einzutragen", ich verstehe nicht?

Re: Bug Report Theli v3

BeitragVerfasst: Sonntag 8. November 2020, 18:48
von dietmar
Moin,

"wenn man vergessen hat was einzutragen", da war das Hirn wieder schneller als die Finger :).
Ich hatte langer Theli-Abstinenz wegen schlechtem Wetter (im Norden ist jetzt Herbst) vergessen in der Sky subtraction den Defaults-Button zu klicken. Daraufhin hat Theli sich verabschiedet.

Egal: offenbar hast Du meine Änderung bereits heute Mittag (MEZ) eingebaut und zwar an 3 Stellen, ich hab's nur an der Einen geändert, die mir der Debugger gezeigt hat.

Viel Spaß noch
Dietmar

Re: Bug Report Theli v3

BeitragVerfasst: Samstag 14. November 2020, 14:54
von dietmar
Moin Mischa,

ich hab' da noch 'ne Anmerkung zu Deiner letzten Commit-message, nur um Missverständnisse zu vermeiden:
Ich hab' nichts explizit auf Null gesetzt! Ich hab' nur aufgeräumt. Theli hat dann beim nächsten Start die letzte Projektdatei nicht gefunden und das Feld für die Kernelbreite leer gelassen. Daraufhin ist es mir um die Ohren geflogen, denn Leerstring.toInt() gibt 0.

Dietmar

Re: Bug Report Theli v3

BeitragVerfasst: Sonntag 15. November 2020, 09:49
von mischa
Hi Dietmar,

das habe ich auch so verstanden :-)
Normalerweise setzt THELI defaults ein, wenn bestimmte Felder leergelassen werden aber benoetigt werden. In dem fall hab ich das wohl uebersehen.

mischa