Hot/Cold Pixel glattbügeln

Wie arbeite ich mit Theli, wie verarbeite ich in Theli erstellten Bilder ?

Hot/Cold Pixel glattbügeln

Beitragvon astrofoto.harz » Freitag 12. März 2021, 10:06

Hallo Thelianer,
ehrlich gesagt, vermisse ich solch eine Funktion in THELI nicht, sie gehört da thematisch nicht rein, trotzdem würde ich gern wissen, wie ihr dieses Problem löst:

Ich habe verschiedene Datensätze bei mir rumfliegen, wo ich nicht weiterkomme, da ich mit den DARKs wohl nicht sorgfältig genug war bzw. ein Bug in der Kamerasoftware mir den Zustand der Kamera Kühlung falsch angezeigt hat. Das führt dazu, dass nach der Kalibrierung signifikant abweichende Pixel in den Einzelframes vor den Astrometrieren und Stacken zurückbleiben. Da ich die Aufnahme gedithert habe, sieht man nach der Koaddition unansehliche Pixelhäufchen.
Leider funktioniert das Kalibrieren ohne DARKs nicht, THELI stürzt dabei ab.

Welche Möglichkeiten habe ich jetzt?

1. In PixInsight gibt es die Funktion "Cosmetic Correction" die das Problem ganz gut in einem Batch-Durchlauf behandelt, allerdings ändert PixInsight das Datenformat, so dass ich anschließend nicht mit THELI weiter koaddieren kann. Hilfreich wäre hier ein kleines Kommandozeilen-Tool unter Linux, dass alle Frames im Verzeichnis einfach durchrödelt und die abweichnenden Pixel angleicht. Existiert so etwas?

2. Soll ich die DARKs wegwerfen und einfach ein künstliches Masterdark (alle Pixel auf "0") verwenden?

CS, Olaf
astrofoto.harz
 
Beiträge: 11
Registriert: Mittwoch 13. April 2016, 10:57

Re: Hot/Cold Pixel glattbügeln

Beitragvon mischa » Freitag 12. März 2021, 16:21

Hi Olaf,

ich habe viele datensaetze verarbeitet ohne darks und Bias, und dabei kein problem entdeckt. Was genau machst du, so dass der Absturz passiert? Und wann passiert er?

Wenn deine Aufnahmen gut gedithert sind, kannst du mal bei der Koaddition "median" statt "weighted" versuchen, das sollte ganz gut helfen.

mischa
mischa
Moderator
 
Beiträge: 1253
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Hot/Cold Pixel glattbügeln

Beitragvon astrofoto.harz » Freitag 12. März 2021, 20:44

Hallo mischa,
ich habe mittlerweile eine workaround gefunden:
Wenn ich das Setting "Minimize memory usage" deaktiviere, läuft die Kalibrierung ohne Dark durch.

Bei aktiviertem "Minimize memory usage" komme ich bis zu - siehe Screenshot.
theli.png


Wenn ich nur BIAS verwende und "Median" in der Koaddition sieht das Endergebnis tatsächlich besser aus. Danke für den Tip!

CS, Olaf
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
astrofoto.harz
 
Beiträge: 11
Registriert: Mittwoch 13. April 2016, 10:57

Re: Hot/Cold Pixel glattbügeln

Beitragvon mischa » Samstag 13. März 2021, 11:50

Der Absturz darf nicht sein. Hast du mal den neuesten master Branch runtergeladen und es damit versucht? Wenn das nicht hilft, dann lad mir mal einen Beispieldatensatz hoch, wo ich das nachvollziehen kann.
Zusammen mit deiner "kamera.ini", zu finden unter ${HOME}/.theli/instruments_user/

LG,

mischa
mischa
Moderator
 
Beiträge: 1253
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: Hot/Cold Pixel glattbügeln

Beitragvon astrofoto.harz » Freitag 19. März 2021, 11:07

Hallo mischa,
ich habe wieder ein system-spezifisches Problem.
Als Referenz habe ich mir gerade VirtualBox/Ubuntu 20.10 + Theli aus dem Repository installiert und nochmal getestet. Hier läuft alles problemlos durch.

CS, Olaf
astrofoto.harz
 
Beiträge: 11
Registriert: Mittwoch 13. April 2016, 10:57

Re: Hot/Cold Pixel glattbügeln

Beitragvon dietmar » Freitag 26. März 2021, 13:01

Moin,
astrofoto.harz hat geschrieben:ehrlich gesagt, vermisse ich solch eine Funktion in THELI nicht, sie gehört da thematisch nicht rein, ...
find' ich doch.

Sollte die "Outlier rejection" in Kombination mit Dithering nicht die Hot und Cold Pixel glattbügeln, die nach der Dark-Subtraction übrig geblieben sind?
Wenn nicht: was macht die sonst?

Viel Spaß noch
Dietmar
dietmar
 
Beiträge: 147
Registriert: Montag 24. Februar 2014, 11:41
Wohnort: Hilden (in der Lichtglocke von Düsseldorf)

Re: Hot/Cold Pixel glattbügeln

Beitragvon astrofoto.harz » Freitag 26. März 2021, 17:43

astrofoto.harz hat geschrieben:Hallo mischa,
ich habe wieder ein system-spezifisches Problem.
Als Referenz habe ich mir gerade VirtualBox/Ubuntu 20.10 + Theli aus dem Repository installiert und nochmal getestet. Hier läuft alles problemlos durch.
CS, Olaf


Ursache war wieder eine falsche cfitsio lib, die beim THELI-Build angezogen wurde. astronomy.net installiert unter Mint 19.3 tricia eine, die ohne reentrant multithreading kompiliert ist.

CS, Olaf
astrofoto.harz
 
Beiträge: 11
Registriert: Mittwoch 13. April 2016, 10:57

Re: Hot/Cold Pixel glattbügeln

Beitragvon mischa » Samstag 27. März 2021, 10:06

astrofoto.harz hat geschrieben:Ursache war wieder eine falsche cfitsio lib, die beim THELI-Build angezogen wurde. astronomy.net installiert unter Mint 19.3 tricia eine, die ohne reentrant multithreading kompiliert ist.


Argh! Troztdem, seit einiger Zeit testet THELI intern ob die cfitsio Bibliothek "reentrant" ist, und wenn nicht, gibt es eine Fehlermeldung. Welche version verwendest du denn?

mischa
mischa
Moderator
 
Beiträge: 1253
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile


Zurück zu Arbeiten mit Theli

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron