astrometrie mit scamp klemmt (png)

Das Herz von Thel.

astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Mittwoch 14. Oktober 2020, 20:33

Tach zusammen,
ich hab gerade theli mit dem debian paket unter ubuntu 20.10 installiert.
Jetzt bleibt die Astrometrie aber hängen. Ich schätze der hängt in einer Schleife. Letzte Meldungen:


Initializing the global photometry matrix...
Solving the global photometry matrix... ----- Photometric stats internal:
7m All detections
High S/N7m Instru mag RMS chi2 ndets mag RMS chi2 ndets0m
Group 1: P1 0.179 68 45026 0.157 86 37056 ----- Photometric stats external:All detections
High S/N7m Instru mag RMS chi2 nstars mag RMS chi2 nstars0m Merging detections...
Computing global color indices
Saving image headers...
Generating group plots...
Requested device png not available


Muss ich da was nachinstallieren? Wie kann ich rausfinden wo er da genau hängt? cpu und speicher machen irgendwas aber es geht nicht weiter... in 1/2h von 57% auf 62%

Gruß /Hendrik/
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon mischa » Donnerstag 15. Oktober 2020, 08:58

Hi Hendrik,

du hast THELI also mit 'sudo apt install theli" installiert? Da sollte eigentlich alles mitkommen, scheint aber dass dir noch "libpng-dev" fehlt. Versuch mal, das nachzuinstallieren. In der Zwischenzeit frage ich mal den Kay, der hat das Debian Paket aufgesetzt.

mischa
mischa
Moderator
 
Beiträge: 1221
Registriert: Freitag 7. Oktober 2011, 14:07
Wohnort: Chile

Re: astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Donnerstag 15. Oktober 2020, 20:17

Hallo Mischa,
Ja ich habe auf ein frisches Ubuntu 20.10 'sudo apt install theli gemacht.
Aber Moment: mit dem Paket "libpng-dev" hab ich doch rumgefummelt als ich versucht habe Astrometry.net zu installieren.
Ich setze das Ubuntu nochmal neu auf und teste nochmal.

/Hendrik/
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon dietmar » Donnerstag 15. Oktober 2020, 22:19

Moin Hendrik,

is' Quatsch, das 'dev' in libirgendwas-dev steht für 'developer', nicht 'device'. Das enthält die Headerfiles für die Library und 'n Symlink für den Buildtime-Linker. Für 'n Binärpaket brauchst Du das nicht.
Was Dir fehlt ist das Plplot-device für PNG, also das Plugin, das weiss, wie man PNG's schreibt.

Viel Spaß noch
Dietmar
dietmar
 
Beiträge: 123
Registriert: Montag 24. Februar 2014, 11:41
Wohnort: Hilden (in der Lichtglocke von Düsseldorf)

Re: astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Freitag 16. Oktober 2020, 16:34

Hallo Dietmar,
ja das Paket libpng-dev löst das Problem nicht.

Wie komme ich denn an das Plplot-device dran? Kann ich da ein Paket nachinstallieren? Die Doku von PLplot ist ja etwas umfangreicher...

/Hendrik/
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon dietmar » Freitag 16. Oktober 2020, 18:56

Moin Hendrik,

das ist 'n gute Frage (einfache Fragen kann auch jeder beantworten :wink: ).
Hier schreiben sie cairo sei dafür zuständig. Hab' ich nicht, geht trotzdem. Bei mir sieht das so aus:
Code: Alles auswählen
$ dpkg-query -l \*plplot\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                          Version       Architecture Description
+++-=============================-=============-============-==================================================
un  libplplot-d                   <none>        <none>       (no description available)
ii  libplplot-dev                 5.14.0+dfsg-3 amd64        Scientific plotting library (development files)
un  libplplot-fortran9            <none>        <none>       (no description available)
ii  libplplot-lua:amd64           5.14.0+dfsg-3 amd64        Scientific plotting library (Lua bindings)
ii  libplplot-ocaml               5.14.0+dfsg-3 amd64        OCaml bindings for the scientific plotting library
un  libplplot-ocaml-3jrv7         <none>        <none>       (no description available)
ii  libplplot16:amd64             5.14.0+dfsg-3 amd64        Scientific plotting library
ii  libplplotcxx14:amd64          5.14.0+dfsg-3 amd64        Scientific plotting library (C++ binding)
ii  libplplotfortran0:amd64       5.14.0+dfsg-3 amd64        Scientific plotting library (fortran bindings)
ii  libplplotqt2:amd64            5.14.0+dfsg-3 amd64        Scientific plotting library (Qt bindings)
ii  libplplotwxwidgets1:amd64     5.14.0+dfsg-3 amd64        Scientific plotting library (wxWidgets bindings)
un  plplot-bin                    <none>        <none>       (no description available)
un  plplot-doc                    <none>        <none>       (no description available)
un  plplot-driver-cairo           <none>        <none>       (no description available)
un  plplot-driver-gd              <none>        <none>       (no description available)
ii  plplot-driver-qt              5.14.0+dfsg-3 amd64        Scientific plotting library (Qt driver)
ii  plplot-driver-wxwidgets:amd64 5.14.0+dfsg-3 amd64        Scientific plotting library (wxWidgets driver)
un  plplot-driver-xwin            <none>        <none>       (no description available)
un  plplot-tcl                    <none>        <none>       (no description available)
un  plplot12-driver-qt            <none>        <none>       (no description available)
un  plplot12-driver-wxwidgets     <none>        <none>       (no description available)
Ich meine mich aber dunkel erinnern zu können, sowas auch schon gehabt zu haben:
War's 'ne verkehrte PLplot-Version?
Die verkehrte scamp-version?
Hatte ich scamp ohne PLplot übersetzt?
Ich kann mich nicht erinnern.

Hast Du das scamp aus der Distri oder selbst übersetzt? Welche Version?
Code: Alles auswählen
$ scamp -v
SCAMP version 2.9.0 (2020-04-28)


Viel Spaß noch
Dietmar
dietmar
 
Beiträge: 123
Registriert: Montag 24. Februar 2014, 11:41
Wohnort: Hilden (in der Lichtglocke von Düsseldorf)

Re: astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Freitag 16. Oktober 2020, 20:01

Hallo Dietmar, ja da ist wohl was faul mit scamp

Code: Alles auswählen
standard@astronomy:~$ scamp -v
SCAMP version 2.0.4 (2014-07-09)

Das passt eher zu theli V2 :-)

Ich hatte ja extra versucht nur das Debian Paket zu verwenden. Also nur:
Ubuntu 20.10 installiert (ohne den Haken bei "zusätzliche Treiber und Medienformate")
dann
Code: Alles auswählen
sudo apt install theli

und sonst nix.

Wäre auch zu einfach gewesen...
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon dietmar » Freitag 16. Oktober 2020, 20:34

eisentpferd hat geschrieben:Ubuntu 20.10 installiert (ohne den Haken bei "zusätzliche Treiber und Medienformate")
Hä? Versteh' kein Wort.

Du könntest mal versuchen Scamp-2.9.0 in dein Homedirectory oder nach /usr/local zu installieren und gucken ob's dann geht.
Dabei darauf achten, dass $HOME/bin, bzw. /usr/local/bin vor /usr/bin in PATH steht:
Code: Alles auswählen
$ echo $PATH
/home/didi/bin:/home/didi/astro/astrometry/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

Dietmar
dietmar
 
Beiträge: 123
Registriert: Montag 24. Februar 2014, 11:41
Wohnort: Hilden (in der Lichtglocke von Düsseldorf)

Re: astrometrie mit scamp klemmt (png)

Beitragvon bocca » Freitag 16. Oktober 2020, 21:59

Hallo Hendrik,

eigentlich sollte ein

apt install theli

ausreichend sein.
Alle notwendigen Pakete inkl. scamp werden mit installiert.

Zum Bauen braucht man die verschiedenen lib###-dev Bibliotheken, die man eigentlich zur Laufzeit nicht braucht.

Das sind folgende:
debhelper-compat (= 13),
python3,
python3-requests,
libfftw3-dev,
libtiff-dev,
curl,
libcurl4,
libcurl4-gnutls-dev,
qtbase5-dev,
qtchooser,
qt5-qmake,
libgsl-dev,
libatlas-base-dev,
libblas-dev,
libplplot-dev,
libcfitsio-dev,
libwcstools-dev,
wcslib-dev,
liblapack-dev,
git,
scamp (>= 2.0.4),
libraw-dev

Vielleicht fehlt noch eine libplplot##.

Was kommt bei Dir bei:
apt list --installed | grep plplot ?

Ich lade mir auch mal Ubuntu 20.10 runter und teste damit. Wird aber einen Moment dauern ;-) (...download dauert schon mal bei mir 4h ;-( )

Viele Grüße,
Kay
bocca
 
Beiträge: 44
Registriert: Samstag 22. Oktober 2011, 05:45

Re: astrometrie mit scamp klemmt (png)

Beitragvon bocca » Freitag 16. Oktober 2020, 22:25

Hallo,

ich habe auch noch mal rumgegoogelt...

Hier (wie von Dietmar schon erwähnt) kann man den Verweis auf plplot9-driver-cairo finden und daß png jetzt in plplot depricated ist.
https://sourceforge.net/p/plplot/mailma ... /26728060/

----
We deprecated that starting
with release 5.9.3 for the reasons mentioned in our release
announcements for 5.9.3 and subsequent releases.
----

Wie gesagt, wenn ich mein Ubuntu 20.10 habe schaue ich mir das mal an.

Viele Grüße,
Kay
bocca
 
Beiträge: 44
Registriert: Samstag 22. Oktober 2011, 05:45

Re: astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Samstag 17. Oktober 2020, 06:50

Hallo zusammen, es sieht halt so aus dass das Debian Paket ein altes scamp installiert hat.
Die andere Abfrage mach ich später...
Danke /Hendrik/
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon bocca » Samstag 17. Oktober 2020, 08:01

Hallo Hendrik,

ich konnte das Problem nachstellen.

Installier mal bitte noch:

sudo apt install plplot-driver-cairo

Dann sollte es funktionieren.

Das muß ich noch in die Abhängigkeiten aufnehmen.

Komischerweise ist in Ubuntu 20.10 SCAMP version 2.0.4 (2014-07-09). Ich hätte eine neuere erwartet. Aber theli kann auch mit dieser Version arbeiten.

Viele Grüße,
Kay
bocca
 
Beiträge: 44
Registriert: Samstag 22. Oktober 2011, 05:45

Re: astrometrie mit scamp klemmt (png)

Beitragvon bocca » Samstag 17. Oktober 2020, 08:07

eisentpferd hat geschrieben:Hallo zusammen, es sieht halt so aus dass das Debian Paket ein altes scamp installiert hat.
Die andere Abfrage mach ich später...
Danke /Hendrik/



Lt. dieser Seite ist aber scamp 2.0.4 in Ubuntu 20.10 enthalten:
https://packages.ubuntu.com/groovy/allpackages

Eine dedizierte Installation installiert auch "nur" Version 2.0.4.

Ich hätte eher 2.9.2 erwartet, so wie hier beschrieben: https://ubuntu.pkgs.org/20.10/ubuntu-pr ... 4.deb.html
Denn in Debian unstable ist auch SCAMP version 2.9.2 (2020-06-05)

... vielleicht kommt das noch bis zum offiziellen release.

Aber wie gesagt, Dein Problem ist eher das fehlende plplot.

Viele Grüße,
Kay
bocca
 
Beiträge: 44
Registriert: Samstag 22. Oktober 2011, 05:45

Re: astrometrie mit scamp klemmt (png)

Beitragvon eisentpferd » Samstag 17. Oktober 2020, 09:24

Hallo Kai,
besten Dank. Ja das hat geklappt. Nach installation von plplot mit
sudo apt install plplot-driver-cairo
rennt scamp durch und es kommen auch plots. Die alte Scamp Version scheint nicht zu stören. Es ist auch schnell und es werden alle Kerne benutzt.
Wenn Du das Paket aktualisiert hast sag Bescheid, dann teste ich nochmal und schreibe einen Bericht hier im Forum unter "Installation".

Wie ist das eigentlich mit Updates wenn ich nur mittels Debian Paket installiere? Wenn Mischa zB. ein Update auf Github veröffentlicht. Wie käme ich dann da dran?

Gruß /Hendrik/
eisentpferd
 
Beiträge: 46
Registriert: Sonntag 12. Januar 2020, 21:14

Re: astrometrie mit scamp klemmt (png)

Beitragvon bocca » Samstag 17. Oktober 2020, 09:47

Hallo Hendrik,
prima, dass es geklappt hat.

Das Vorgehen wäre jetzt folgendes:

Ich passe das Debian Paket an und lade es ins Debian Repository hoch.
Dieses wird dann von der Debian Astronomy Group geprüft (Ole Streicher) und für Debian unstable zur Verfügung gestellt.
Von da aus kommt das Paket dann in Ubuntu 20.10 .

Viele Grüße,
Kay
bocca
 
Beiträge: 44
Registriert: Samstag 22. Oktober 2011, 05:45

Nächste

Zurück zu Astrometrie und Photometrie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron